Make sure binutils does not leak system libraries into the build.
authorEric Andersen <andersen@codepoet.org>
Tue, 2 Sep 2003 12:22:02 +0000 (12:22 -0000)
committerEric Andersen <andersen@codepoet.org>
Tue, 2 Sep 2003 12:22:02 +0000 (12:22 -0000)
patch from mjn3 to prevent gcc using broken include paths

make/uclibc_toolchain.mk
sources/gcc-006-include-search.patch [new file with mode: 0644]

index 94e3823cf47ac228b09dbe4cb2de277f17085e83..cdc5321a7799bed4751a29740482178bc991b473 100644 (file)
@@ -148,8 +148,8 @@ $(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched
                --mandir=$(STAGING_DIR)/man \
                --infodir=$(STAGING_DIR)/info \
                --enable-targets=$(GNU_TARGET_NAME) \
-               --with-lib-path="/usr/lib:/lib" \
                --with-sysroot=$(STAGING_DIR) \
+               --with-lib-path="$(STAGING_DIR)/usr/lib:$(STAGING_DIR)/lib" \
                $(MULTILIB) \
                --program-prefix=$(ARCH)-uclibc-);
        touch $(BINUTILS_DIR1)/.configured
diff --git a/sources/gcc-006-include-search.patch b/sources/gcc-006-include-search.patch
new file mode 100644 (file)
index 0000000..44a310a
--- /dev/null
@@ -0,0 +1,18 @@
+--- gcc-3.3.1/gcc/cppinit.c.old        2003-08-29 17:08:57.000000000 -0500
++++ gcc-3.3.1/gcc/cppinit.c    2003-08-29 16:53:36.000000000 -0500
+@@ -787,6 +787,7 @@
+   if (path != 0 && *path != 0)
+     path_include (pfile, path, SYSTEM);
++#if 0
+   /* Search "translated" versions of GNU directories.
+      These have /usr/local/lib/gcc... replaced by specd_prefix.  */
+   if (specd_prefix != 0 && cpp_GCC_INCLUDE_DIR_len)
+@@ -824,6 +825,7 @@
+           }
+       }
+     }
++#endif
+   /* Search ordinary names for GNU include directories.  */
+   for (p = cpp_include_defaults; p->fname; p++)