quagga: option for vtysh
authorMatt Weber <matthew.weber@rockwellcollins.com>
Tue, 17 Mar 2015 23:15:43 +0000 (18:15 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Mar 2015 22:20:40 +0000 (23:20 +0100)
[Thomas: add corresponding explicit --disable option.]

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/quagga/Config.in
package/quagga/quagga.mk

index d8b10f8520c09f6574d83acf9f9db9d9052ccfcb..4a9f8bb0d8d35c4aedef3f2d0c5254c6526343d6 100644 (file)
@@ -82,6 +82,12 @@ config BR2_PACKAGE_QUAGGA_WATCHQUAGGA
        help
          Build and install watchquagga, a zebra/protocol daemon supervisor.
 
+config BR2_PACKAGE_QUAGGA_VTYSH
+       bool "Build vtysh"
+       select BR2_PACKAGE_READLINE
+       help
+         Build and install vtysh, a vty shell for Quagga.
+
 config BR2_PACKAGE_QUAGGA_SNMP
        bool "SNMP support"
        depends on BR2_USE_MMU # net-snmp
index 2c0a6a9901b628a43b86b940d014ae03e2b49a74..756d6e0e18f709a0c7cf1a5389685dd90e2abf8b 100644 (file)
@@ -32,4 +32,11 @@ QUAGGA_CONF_OPTS += --enable-snmp=agentx
 QUAGGA_DEPENDENCIES += netsnmp
 endif
 
+ifeq ($(BR2_PACKAGE_QUAGGA_VTYSH),y)
+QUAGGA_CONF_OPTS += --enable-vtysh
+QUAGGA_DEPENDENCIES += readline
+else
+QUAGGA_CONF_OPTS += --disable-vtysh
+endif
+
 $(eval $(autotools-package))