luajit: clean fuzz/offset in patches
authorFrancois Perrad <fperrad@gmail.com>
Tue, 2 Jun 2015 16:32:59 +0000 (18:32 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 2 Jun 2015 20:48:35 +0000 (22:48 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/luajit/0001-no-bin-symlink.patch
package/luajit/0002-install-inc.patch
package/luajit/0003-install-so.patch

index 6391f399abdab41730549a9589717cac611fb107..37298dd7c7d58d033f81720fdf55536c0710690c 100644 (file)
@@ -6,7 +6,7 @@ Index: b/Makefile
 ===================================================================
 --- a/Makefile
 +++ b/Makefile
-@@ -42,8 +42,7 @@
+@@ -43,8 +43,7 @@
  INSTALL_MAN= $(INSTALL_SHARE)/man/man1
  INSTALL_PKGCONFIG= $(INSTALL_LIB)/pkgconfig
  
@@ -16,7 +16,7 @@ Index: b/Makefile
  INSTALL_ANAME= libluajit-$(ABIVER).a
  INSTALL_SONAME= libluajit-$(ABIVER).so.$(MAJVER).$(MINVER).$(RELVER)
  INSTALL_SOSHORT= libluajit-$(ABIVER).so
-@@ -57,7 +56,6 @@
+@@ -58,7 +57,6 @@
  INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
  INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
  INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
index 1fd11b1a17525fa80decd65508286183ba03a6a4..86b766dfc4427e4f6b637ff4058948a58e03b152 100644 (file)
@@ -6,9 +6,9 @@ Index: b/Makefile
 ===================================================================
 --- a/Makefile
 +++ b/Makefile
-@@ -31,7 +31,7 @@ DPREFIX= $(DESTDIR)$(PREFIX)
+@@ -32,7 +32,7 @@
  INSTALL_BIN=   $(DPREFIX)/bin
- INSTALL_LIB=   $(DPREFIX)/lib
+ INSTALL_LIB=   $(DPREFIX)/$(MULTILIB)
  INSTALL_SHARE= $(DPREFIX)/share
 -INSTALL_INC=   $(DPREFIX)/include/luajit-$(MAJVER).$(MINVER)
 +INSTALL_INC=   $(DPREFIX)/include
index 738ec07716b4f3ba532054d405f835c955b56918..5929595abe37757d5e05df26b40b7ef4502dcb49 100644 (file)
@@ -11,12 +11,12 @@ Index: b/Makefile
 ===================================================================
 --- a/Makefile
 +++ b/Makefile
-@@ -56,7 +56,7 @@
+@@ -55,7 +55,7 @@
  INSTALL_STATIC= $(INSTALL_LIB)/$(INSTALL_ANAME)
  INSTALL_DYN= $(INSTALL_LIB)/$(INSTALL_SONAME)
  INSTALL_SHORT1= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
 -INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT)
 +INSTALL_SHORT2= $(INSTALL_LIB)/$(INSTALL_SOSHORT).$(MAJVER)
  INSTALL_T= $(INSTALL_BIN)/$(INSTALL_TNAME)
- INSTALL_TSYM= $(INSTALL_BIN)/$(INSTALL_TSYMNAME)
  INSTALL_PC= $(INSTALL_PKGCONFIG)/$(INSTALL_PCNAME)