gstreamer: Allow libxml2 dependency to be configured.
authorWill Newton <will.newton@gmail.com>
Tue, 16 Jun 2009 20:33:56 +0000 (21:33 +0100)
committerWill Newton <will.newton@gmail.com>
Tue, 16 Jun 2009 20:37:35 +0000 (21:37 +0100)
gstreamer uses libxml2 to support the plugin registry and pipeline
load/save features. This change allows the user to build gstreamer without
libxml2 which saves a large amount of space on the target.

Closes #373.

Signed-off-by: Will Newton <will.newton@gmail.com>
package/multimedia/gstreamer/Config.in
package/multimedia/gstreamer/gstreamer.mk

index 213d650103f37e339052d62690bcec86bcc1cddb..8c8080173072b3cdd66467685812a1aaf2eafa37 100644 (file)
@@ -1,8 +1,13 @@
 config BR2_PACKAGE_GSTREAMER
        bool "gstreamer"
        select BR2_PACKAGE_LIBGLIB2
-       select BR2_PACKAGE_LIBXML2
        help
          GStreamer is an open source multimedia framework.
 
          http://gstreamer.freedesktop.org/
+
+config BR2_PACKAGE_GSTREAMER_LIBXML2
+       bool "require libxml2 for registry and load/save"
+       default y
+       select BR2_PACKAGE_LIBXML2
+       depends on BR2_PACKAGE_GSTREAMER
index 8b30209b7f1225385cf9e00231910f4423d60f7f..821a2334979b8e6e1e904c41fbf0469fbe99c015 100644 (file)
@@ -24,6 +24,14 @@ GSTREAMER_CONF_OPT = \
                --disable-tests \
                --disable-failing-tests
 
-GSTREAMER_DEPENDENCIES = libglib2 libxml2 host-pkgconfig
+GSTREAMER_DEPENDENCIES = libglib2 host-pkgconfig
+
+ifeq ($(BR2_PACKAGE_GSTREAMER_LIBXML2),y)
+GSTREAMER_DEPENDENCIES += libxml2
+else
+GSTREAMER_CONF_OPT += \
+       --disable-registry \
+       --disable-loadsave
+endif
 
 $(eval $(call AUTOTARGETS,package/multimedia,gstreamer))