package/openswan: fix parallel build
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 14 Jul 2015 10:53:42 +0000 (12:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Jul 2015 11:04:12 +0000 (13:04 +0200)
Fixes:
    http://autobuild.buildroot.org/results/2ec/2ecb098b01bd44d75182b15f98c1fd2a8c927438/
    http://autobuild.buildroot.org/results/18f/18f0166f3fa831f321818e286d9c2e9037f8c8d0/
    ...

Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openswan/openswan.mk

index 6c6a8a776aa44018842fb9616cfcd706021932bd..b7689c14a700ca1f08d165b1026f910cf5598ee7 100644 (file)
@@ -29,12 +29,12 @@ endif
 endif
 
 define OPENSWAN_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+       $(TARGET_MAKE_ENV) $(MAKE1) -C $(@D) \
                $(OPENSWAN_MAKE_OPTS) programs
 endef
 
 define OPENSWAN_INSTALL_TARGET_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) \
+       $(TARGET_MAKE_ENV) $(MAKE1) -C $(@D) \
                $(OPENSWAN_MAKE_OPTS) DESTDIR=$(TARGET_DIR) install
 endef