infra/pkg-kconfig: require an non-empty KCONFIG_FILE
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 8 Apr 2015 17:08:35 +0000 (19:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 10 Jun 2015 07:27:05 +0000 (09:27 +0200)
Currently, we only check that the variable is defined, which is not
enough since we really want it to be non-empty.

We however can't check it points to an existing file, because the
package might well not be extracted yet, and we may use an internal
defconfig. If that file does not eventually exist, there will be a
failure down the road at build time when we try to copy it...

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-kconfig.mk

index dcaed53dd2742807db5dc7d43f4c592eaecaa372..7a00fff393384f5277224a51b29374a5198eb1b1 100644 (file)
@@ -70,7 +70,7 @@ $$($(2)_TARGET_CONFIGURE): $$($(2)_DIR)/.stamp_kconfig_fixup_done
 ifeq ($$($$($(2)_KCONFIG_VAR)),y)
 
 # FOO_KCONFIG_FILE is required
-ifndef $(2)_KCONFIG_FILE
+ifeq ($$($(2)_KCONFIG_FILE),)
 $$(error Internal error: no value specified for $(2)_KCONFIG_FILE)
 endif