wine: add optional dependency on libkrb5
authorAndré Hentschel <nerv@dawncrow.de>
Sat, 7 Apr 2018 11:57:52 +0000 (13:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 9 Apr 2018 09:15:30 +0000 (11:15 +0200)
Signed-off-by: André Hentschel <nerv@dawncrow.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/wine/wine.mk

index 02c4c0f1554341e9c36019fa4671a627d74ebd39..b6b3aae504b6e74e254ca1c920c200e74c0e39e7 100644 (file)
@@ -23,7 +23,6 @@ WINE_CONF_OPTS = \
        --without-gphoto \
        --without-gsm \
        --without-hal \
-       --without-krb5 \
        --without-opencl \
        --without-oss
 
@@ -121,6 +120,13 @@ else
 WINE_CONF_OPTS += --without-glu
 endif
 
+ifeq ($(BR2_PACKAGE_LIBKRB5),y)
+WINE_CONF_OPTS += --with-krb5
+WINE_DEPENDENCIES += libkrb5
+else
+WINE_CONF_OPTS += --without-krb5
+endif
+
 ifeq ($(BR2_PACKAGE_LIBPCAP),y)
 WINE_CONF_OPTS += --with-pcap
 WINE_DEPENDENCIES += libpcap