package/minetest: add NLS optional dependency
authorRomain Naour <romain.naour@gmail.com>
Thu, 13 Jul 2017 12:40:45 +0000 (14:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 21 Oct 2017 15:19:32 +0000 (17:19 +0200)
Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/minetest/minetest.mk

index de4e3f01846739dae78ec19365d674215640db16..316bd9bc83ea2f732b2b4cef36f5c22d623af08e 100644 (file)
@@ -13,7 +13,6 @@ MINETEST_DEPENDENCIES = gmp irrlicht jsoncpp luajit sqlite zlib
 
 MINETEST_CONF_OPTS = \
        -DDEFAULT_RUN_IN_PLACE=OFF \
-       -DENABLE_GETTEXT=OFF \
        -DENABLE_SOUND=OFF \
        -DENABLE_GLES=OFF \
        -DENABLE_FREETYPE=OFF \
@@ -47,4 +46,11 @@ else
 MINETEST_CONF_OPTS += -DENABLE_CURL=OFF
 endif
 
+ifeq ($(BR2_SYSTEM_ENABLE_NLS),y)
+MINETEST_DEPENDENCIES += $(TARGET_NLS_DEPENDENCIES)
+MINETEST_CONF_OPTS += -DENABLE_GETTEXT=ON
+else
+MINETEST_CONF_OPTS += -DENABLE_GETTEXT=OFF
+endif
+
 $(eval $(cmake-package))