ebtables: add error handling to for loop
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 30 Nov 2014 14:18:28 +0000 (15:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 1 Dec 2014 22:30:01 +0000 (23:30 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ebtables/ebtables.mk

index 578c3ae805a03d718065f0394d793c1ec9adb6e3..23c462874e7817ec415f80721519d2c9cd30dea7 100644 (file)
@@ -28,7 +28,7 @@ define EBTABLES_INSTALL_TARGET_CMDS
                $(@D)/$(EBTABLES_SUBDIR)/extensions/*.so; \
                do \
                $(INSTALL) -m 0755 -D $${so} \
-                       $(TARGET_DIR)/lib/ebtables/`basename $${so}`; \
+                       $(TARGET_DIR)/lib/ebtables/`basename $${so}` || exit 1; \
        done
        $(INSTALL) -m 0755 -D $(@D)/$(EBTABLES_SUBDIR)/ebtables \
                $(TARGET_DIR)/sbin/ebtables