core/pkg-generic: check proper package installation
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 24 Oct 2016 16:38:52 +0000 (18:38 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 26 Oct 2016 20:36:44 +0000 (22:36 +0200)
Some packages misbehave, and install files in either $(STAGING_DIR)/$(O)
or in $(TARGET_DIR)/$(O) .

One common reason for that is that pkgconf now prepends the sysroot path
to all the paths it returns. Other reasons vary, but are mostly due to
poorly writen generic-packages.

And a new step hooks to check that no file gets installed in either
location, called after the install-target and install-staging steps.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-generic.mk

index 33490929b09fb7abf5fec980648020f610f91081..827de627e84da2aa49c50162cc95817f3841719e 100644 (file)
@@ -95,6 +95,21 @@ define check_host_rpath
 endef
 GLOBAL_INSTRUMENTATION_HOOKS += check_host_rpath
 
+define step_check_build_dir_one
+       if [ -d $(2) ]; then \
+               printf "%s: installs files in %s\n" $(1) $(2) >&2; \
+               exit 1; \
+       fi
+endef
+
+define step_check_build_dir
+       $(if $(filter install-staging,$(2)),\
+               $(if $(filter end,$(1)),$(call step_check_build_dir_one,$(3),$(STAGING_DIR)/$(O))))
+       $(if $(filter install-target,$(2)),\
+               $(if $(filter end,$(1)),$(call step_check_build_dir_one,$(3),$(TARGET_DIR)/$(O))))
+endef
+GLOBAL_INSTRUMENTATION_HOOKS += step_check_build_dir
+
 # User-supplied script
 ifneq ($(BR2_INSTRUMENTATION_SCRIPTS),)
 define step_user