qt: install translations
authorVivien Didelot <vivien.didelot@savoirfairelinux.com>
Thu, 12 Sep 2013 19:12:36 +0000 (15:12 -0400)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 19 Sep 2013 19:41:33 +0000 (21:41 +0200)
The Qt translation files are currently created and moved under
$(STAGING_DIR)/usr/translations but not installed on the target.

This patch defines the translations directory to
/usr/share/qt/translations and defines a QT_INSTALL_TARGET_TRANSLATIONS
macro to deploy them from the staging directory to the target directory.

Signed-off-by: Vivien Didelot <vivien.didelot@savoirfairelinux.com>
Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/qt.mk

index daade3c30c61a8bc731fdef3e38c82cf7597770d..48d39fc50140fb2d353757fb14d9684accb609fd 100644 (file)
@@ -516,6 +516,7 @@ define QT_CONFIGURE_CMDS
                -prefix /usr \
                -plugindir /usr/lib/qt/plugins \
                -importdir /usr/lib/qt/imports \
+               -translationdir /usr/share/qt/translations \
                -hostprefix $(STAGING_DIR) \
                -fast \
                -no-rpath \
@@ -666,6 +667,13 @@ define QT_INSTALL_TARGET_POWERVR
 endef
 endif
 
+define QT_INSTALL_TARGET_TRANSLATIONS
+       if [ -d $(STAGING_DIR)/usr/share/qt/translations/ ] ; then \
+               mkdir -p $(TARGET_DIR)/usr/share/qt/translations ; \
+               cp -dpfr $(STAGING_DIR)/usr/share/qt/translations/* $(TARGET_DIR)/usr/share/qt/translations ; \
+       fi
+endef
+
 define QT_INSTALL_TARGET_CMDS
        $(QT_INSTALL_TARGET_LIBS)
        $(QT_INSTALL_TARGET_PLUGINS)
@@ -673,6 +681,7 @@ define QT_INSTALL_TARGET_CMDS
        $(QT_INSTALL_TARGET_FONTS)
        $(QT_INSTALL_TARGET_FONTS_TTF)
        $(QT_INSTALL_TARGET_POWERVR)
+       $(QT_INSTALL_TARGET_TRANSLATIONS)
 endef
 
 define QT_CLEAN_CMDS