host-openssl: use correct prefix so libssl / libcrypto can be found
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 3 Nov 2014 09:59:06 +0000 (10:59 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 3 Nov 2014 09:59:06 +0000 (10:59 +0100)
Fixes (root cause of):
http://autobuild.buildroot.net/results/d01/d0190a6e5c6b5aa78cfefc29e4e8a4e4b135450b/
http://autobuild.buildroot.net/results/9bb/9bb8defedb8024de83eb3a609ab584efb5d0d2b0/
http://autobuild.buildroot.net/results/e4a/e4a1b298e7e158d3614b89e61d40ef9a00e7ff67/
http://autobuild.buildroot.net/results/5e2/5e24a90058111f7d5618047410f809b45bc165f6/

And many others.

The host version of openssl should be configured to use the host directory
as its prefix and the INSTALL_PREFIX dance shouldn't be used, as otherwise
host-openssl will look in /usr for its libraries.

While we are at it, ensure our host CFLAGS are used similar to how we do for
the target build.  Also enable zlib support as we already list it as a
dependency.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/openssl/openssl.mk

index 7c1c7f033bdab702e2c47db92142cd98ece9c14c..7e30cada4e8f4caf8fe8b4b9fd2e3a21553966bb 100644 (file)
@@ -61,12 +61,13 @@ define HOST_OPENSSL_CONFIGURE_CMDS
        (cd $(@D); \
                $(HOST_CONFIGURE_OPTS) \
                ./config \
-               --prefix=/usr \
-               --openssldir=/etc/ssl \
+               --prefix=$(HOST_DIR)/usr \
+               --openssldir=$(HOST_DIR)/etc/ssl \
                --libdir=/lib \
                shared \
-               no-zlib \
+               zlib-dynamic \
        )
+       $(SED) "s:-O[0-9]:$(HOST_CFLAGS):" $(@D)/Makefile
 endef
 
 define OPENSSL_CONFIGURE_CMDS
@@ -106,7 +107,7 @@ define OPENSSL_INSTALL_STAGING_CMDS
 endef
 
 define HOST_OPENSSL_INSTALL_CMDS
-       $(MAKE1) -C $(@D) INSTALL_PREFIX=$(HOST_DIR) install
+       $(MAKE1) -C $(@D) install
 endef
 
 define OPENSSL_INSTALL_TARGET_CMDS