package/freetype: add harfbuzz optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 1 Oct 2020 20:26:25 +0000 (22:26 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Thu, 1 Oct 2020 20:57:20 +0000 (22:57 +0200)
harfbuzz is an optional dependency (enabled by default) since version
2.5.3 and
https://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=86026a47b345a8c254dd5e6be77bf116737cdafb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/freetype/freetype.mk

index 428531ed08d9d3ab09872fe46c85228b0b5775c9..b0aba78c5151ce0d9b4a2338d1c0b092fbe31dc9 100644 (file)
@@ -15,7 +15,11 @@ FREETYPE_DEPENDENCIES = host-pkgconf
 FREETYPE_CONFIG_SCRIPTS = freetype-config
 
 HOST_FREETYPE_DEPENDENCIES = host-pkgconf
-HOST_FREETYPE_CONF_OPTS = --without-zlib --without-bzip2 --without-png
+HOST_FREETYPE_CONF_OPTS = \
+       --without-bzip2 \
+       --without-harfbuzz \
+       --without-png \
+       --without-zlib
 
 # since 2.9.1 needed for freetype-config install
 FREETYPE_CONF_OPTS += --enable-freetype-config
@@ -35,6 +39,13 @@ else
 FREETYPE_CONF_OPTS += --without-bzip2
 endif
 
+ifeq ($(BR2_PACKAGE_HARFBUZZ),y)
+FREETYPE_DEPENDENCIES += harfbuzz
+FREETYPE_CONF_OPTS += --with-harbuzz
+else
+FREETYPE_CONF_OPTS += --without-harfbuzz
+endif
+
 ifeq ($(BR2_PACKAGE_LIBPNG),y)
 FREETYPE_DEPENDENCIES += libpng
 FREETYPE_CONF_OPTS += --with-png