libssh2: add host variant
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Sun, 4 Feb 2018 18:07:44 +0000 (19:07 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 5 Feb 2018 13:57:47 +0000 (14:57 +0100)
Allow build of host variant of libssh2, which depends on host-openssl.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libssh2/libssh2.mk

index 18e772c7223309235e25faf228526abc526dc7d2..c5b0bd855e5e68e58752e81492bff4f906fcb477 100644 (file)
@@ -40,4 +40,10 @@ else
 LIBSSH2_CONF_OPTS += --without-libz
 endif
 
+HOST_LIBSSH2_DEPENDENCIES += host-openssl
+HOST_LIBSSH2_CONF_OPTS += --with-openssl \
+       --with-libssl-prefix=$(HOST_DIR)/usr \
+       --without-libgcrypt
+
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))