icu: fix build failure for musl
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 12 Dec 2016 20:54:25 +0000 (17:54 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 12 Dec 2016 21:27:10 +0000 (22:27 +0100)
musl doesn't have xlocale.h, and stdtod_l is crippled, so disable it.
See thread from OE:
http://lists.openembedded.org/pipermail/openembedded-core/2016-November/128527.html
Fixes:
http://autobuild.buildroot.net/results/6ca/6caebf0f6c4adf66e67bedd0f04155413a9aa7bd/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/icu/icu.mk

index 12406d7524380086aef56209d09a248e5feb7ece..b9e42de94b2339e2966c90e0edaa588eac09a857 100644 (file)
@@ -25,6 +25,11 @@ ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 ICU_CONF_ENV += LIBS="-latomic"
 endif
 
+# strtod_l() is not supported by musl; also xlocale.h is missing
+ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
+ICU_CONF_ENV += ac_cv_func_strtod_l=no
+endif
+
 HOST_ICU_CONF_OPTS = \
        --disable-samples \
        --disable-tests \