package/freerdp: avoid development warning
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 21 Feb 2015 22:36:18 +0000 (23:36 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Feb 2015 09:48:30 +0000 (10:48 +0100)
FreeRDP still uses old-style variables (about linking interfaces), and
that causes a warning, which explicitly states it is targeted at
developers:

    Policy CMP0022 is not set: INTERFACE_LINK_LIBRARIES defines the link
    interface.  Run "cmake --help-policy CMP0022" for policy details.  Use the
    cmake_policy command to set the policy and suppress this warning.

    Target "freerdp-client" has an INTERFACE_LINK_LIBRARIES property which
    differs from its LINK_INTERFACE_LIBRARIES properties.

    INTERFACE_LINK_LIBRARIES:

      [elided list of stuff]

    LINK_INTERFACE_LIBRARIES:

    This warning is for project developers.  Use -Wno-dev to suppress it.

So, just get rid of it as instructed in that warning message itself.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/freerdp/freerdp.mk

index e873d3307dc3cb4ea08be549e99db352bf8d78cb..5bfdeec2352fd52fcfdbd96b38374236f4296aab 100644 (file)
@@ -12,7 +12,7 @@ FREERDP_DEPENDENCIES = openssl zlib \
 FREERDP_LICENSE = Apache-2.0
 FREERDP_LICENSE_FILES = LICENSE
 
-FREERDP_CONF_OPTS = -DWITH_MANPAGES=OFF
+FREERDP_CONF_OPTS = -DWITH_MANPAGES=OFF -Wno-dev
 
 ifeq ($(BR2_PACKAGE_GSTREAMER),y)
 FREERDP_CONF_OPTS += -DWITH_GSTREAMER=ON