openvpn: disable plugins for static builds
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 9 Jul 2014 12:13:17 +0000 (09:13 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 9 Jul 2014 13:46:33 +0000 (15:46 +0200)
Fixes:
http://autobuild.buildroot.net/results/082/08295cdcb3d14198bc7fbddec89d6fead946afba/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/openvpn/openvpn.mk

index 3cb78a50228e948e2b2278199eef257018a79bc0..d2c408b30dafd44582eb58e05b4a423409133745 100644 (file)
@@ -10,7 +10,8 @@ OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
 OPENVPN_DEPENDENCIES = host-pkgconf
 OPENVPN_LICENSE = GPLv2
 OPENVPN_LICENSE_FILES = COPYRIGHT.GPL
-OPENVPN_CONF_OPT = --disable-plugin-auth-pam --enable-iproute2
+OPENVPN_CONF_OPT = --disable-plugin-auth-pam --enable-iproute2 \
+       $(if $(BR2_PREFER_STATIC_LIB),--disable-plugins)
 OPENVPN_CONF_ENV = IFCONFIG=/sbin/ifconfig \
        NETSTAT=/bin/netstat \
        ROUTE=/sbin/route