projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a9cc35d
)
package/systemd: add gnutls support
author
James Hilliard
<james.hilliard1@gmail.com>
Sun, 8 Mar 2020 23:09:37 +0000
(17:09 -0600)
committer
Thomas Petazzoni
<thomas.petazzoni@bootlin.com>
Sun, 12 Apr 2020 13:47:09 +0000
(15:47 +0200)
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/systemd.mk
patch
|
blob
|
history
diff --git
a/package/systemd/systemd.mk
b/package/systemd/systemd.mk
index 14490106aaeae14181026a49ac25d93608a93d19..78a801926f6130e04c8446774883d0ce64990388 100644
(file)
--- a/
package/systemd/systemd.mk
+++ b/
package/systemd/systemd.mk
@@
-70,6
+70,13
@@
else
SYSTEMD_CONF_OPTS += -Delfutils=false
endif
+ifeq ($(BR2_PACKAGE_GNUTLS),y)
+SYSTEMD_DEPENDENCIES += gnutls
+SYSTEMD_CONF_OPTS += -Dgnutls=true
+else
+SYSTEMD_CONF_OPTS += -Dgnutls=false
+endif
+
ifeq ($(BR2_PACKAGE_IPTABLES),y)
SYSTEMD_DEPENDENCIES += iptables
SYSTEMD_CONF_OPTS += -Dlibiptc=true