toolchain-external: bump version of Linaro ARMeb toolchain
authorRomain Naour <romain.naour@gmail.com>
Sat, 24 Sep 2016 09:37:52 +0000 (11:37 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 25 Sep 2016 20:00:49 +0000 (22:00 +0200)
The gdb version is 7.11.1 not 7.10 as stated in the link below [1].
See the manifest to check the version really used [2].

[1] https://releases.linaro.org/components/toolchain/binaries/5.3-2016.05
[2] https://releases.linaro.org/components/toolchain/binaries/5.3-2016.05/armeb-linux-gnueabihf/gcc-linaro-5.3.1-2016.05-linux-manifest.txt

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/toolchain-external.hash
toolchain/toolchain-external/toolchain-external.mk

index ab1ccd51875d5ee1effbf1fe1e18a311d2feaaad..807a667ad89dbdaac5efa2e7a799128b015360d1 100644 (file)
@@ -87,7 +87,7 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARMEB
 
 # See the note above.
 config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARMEB
-       bool "Linaro armeb 2016.02"
+       bool "Linaro armeb 2016.05"
        depends on BR2_armeb
        depends on BR2_ARM_CPU_ARMV7A
        depends on BR2_HOSTARCH = "x86_64"
@@ -101,8 +101,8 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_ARMEB
        select BR2_TOOLCHAIN_GCC_AT_LEAST_5
        help
          Linaro toolchain for the ARM big endian architecture. It
-         uses Linaro GCC 2016.02 (based on gcc 5.3), Linaro GDB
-         2016.02 (based on GDB 7.10), glibc 2.21, Binutils 2015.10
+         uses Linaro GCC 2016.05 (based on gcc 5.3.1), Linaro GDB
+         2016.05 (based on GDB 7.11.1), glibc 2.21, Binutils 2016.05
          (based on 2.25). It generates code that runs on all Cortex-A
          profile devices, but tuned for the Cortex-A9. The code
          generated is Thumb 2, with the hard floating point calling
index 90687416031ade231dbb6cd94621d1b573367aae..1dc7963d77f4fd20c8c449909b4d0182f50b9cc5 100644 (file)
@@ -40,7 +40,7 @@ sha256 eafeb3a5247e9ce31aa35d812e296fba5d5f1443e106d9bef9e38d3ee3ade006  gcc-lin
 sha256 987941c9fffdf56ffcbe90e8984673c16648c477b537fcf43add22fa62f161cd  gcc-linaro-5.3.1-2016.05-x86_64_arm-linux-gnueabihf.tar.xz
 sha256 4bc9d86390f8fa67a693ba4768ba5b12faaf7dd37c706c05ccd9321e765226e4  gcc-linaro-armeb-linux-gnueabihf-4.9-2014.09_linux.tar.xz
 sha256 bf5d3111dad5aa9aef0e955875fb7fc9e918cb24519af7014dd67a9e581a49b1  gcc-linaro-armeb-linux-gnueabihf-4.9-2014.09_src.tar.bz2
-sha256 f488caf46680b0c0a16b66b43fbfd157e3d6389df18e957983132e89529a9804  gcc-linaro-5.3-2016.02-x86_64_armeb-linux-gnueabihf.tar.xz
+sha256 6cf41c8944be56279cc14992aa075174b7a4c5938502536266eaaeef048f9440  gcc-linaro-5.3.1-2016.05-x86_64_armeb-linux-gnueabihf.tar.xz
 sha256 3954f496ab01de67241109e82abfaa9b7625fdab4f05e79e7902e9814a07b832  gcc-linaro-aarch64-linux-gnu-4.9-2014.09_linux.tar.xz
 sha256 a7b8f842fdc9d9be22ca4e0c999429780fc6f16ea798b032421b5ec0cfa53b3e  gcc-linaro-aarch64-linux-gnu-4.9-2014.09_src.tar.bz2
 sha256 1c85af550bedd378be583317b4abbdc96342b42c19fb19873c13d3093ff694ad  gcc-linaro-5.3-2016.02-x86_64_aarch64-linux-gnu.tar.xz
index caa1253316365529111ae69c7eafeaeab3206b83..9fa6fc0a26aba49c4eb6142d5d59cbdbc33d263d 100644 (file)
@@ -345,8 +345,8 @@ TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-armeb-linux-gnueabihf-4.9-2014.09_linux.t
 TOOLCHAIN_EXTERNAL_ACTUAL_SOURCE_TARBALL = gcc-linaro-armeb-linux-gnueabihf-4.9-2014.09_src.tar.bz2
 TOOLCHAIN_EXTERNAL_POST_INSTALL_STAGING_HOOKS += TOOLCHAIN_EXTERNAL_LINARO_SYMLINK
 else
-TOOLCHAIN_EXTERNAL_SITE = https://releases.linaro.org/components/toolchain/binaries/5.3-2016.02/armeb-linux-gnueabihf
-TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-5.3-2016.02-x86_64_armeb-linux-gnueabihf.tar.xz
+TOOLCHAIN_EXTERNAL_SITE = https://releases.linaro.org/components/toolchain/binaries/5.3-2016.05/armeb-linux-gnueabihf
+TOOLCHAIN_EXTERNAL_SOURCE = gcc-linaro-5.3.1-2016.05-x86_64_armeb-linux-gnueabihf.tar.xz
 endif
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS),y)
 TOOLCHAIN_EXTERNAL_SITE = http://sourcery.mentor.com/public/gnu_toolchain/mips-linux-gnu