systemd: add option to enable kdbus support
authorRyan Barnett <ryanbarnett3@gmail.com>
Sun, 5 Apr 2015 22:10:10 +0000 (17:10 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 13 Jul 2015 15:35:20 +0000 (17:35 +0200)
In the future when the kernel offically supports kdbus, this option
should automatically enable the kernel kdbus config option(s).

Signed-off-by: Ryan Barnett <ryanbarnett3@gmail.com>
Tested-by: Mike Williams <mike@mikebwilliams.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/Config.in
package/systemd/systemd.mk

index 303cf2226cd8ff6c390f89b4e555085750a4584b..510baddae73fd8769ce06d313ef7849836dd6e37 100644 (file)
@@ -73,6 +73,11 @@ config BR2_PACKAGE_SYSTEMD_ALL_EXTRAS
          Enable extra features for Systemd: journal compression and
          signing.
 
+config BR2_PACKAGE_SYSTEMD_KDBUS
+       bool "enable kdbus support"
+       help
+         Enable kdbus support for Systemd.
+
 config BR2_PACKAGE_SYSTEMD_JOURNAL_GATEWAY
        bool "HTTP server for journal events"
        select BR2_PACKAGE_LIBMICROHTTPD
index 5c9effa9ffd62ba64a8a0f511bb82293374377b9..b62fc088f68b9068b3a9f01660652841206db9c8 100644 (file)
@@ -71,6 +71,12 @@ else
 SYSTEMD_CONF_OPTS += --disable-seccomp
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_KDBUS),y)
+SYSTEMD_CONF_OPTS += --enable-kdbus
+else
+SYSTEMD_CONF_OPTS += --disable-kdbus
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_ALL_EXTRAS),y)
 SYSTEMD_DEPENDENCIES += xz libgcrypt
 SYSTEMD_CONF_OPTS += \