Revert "Microblaze: build kernel with device tree"
authorMaxime Ripard <maxime.ripard@free-electrons.com>
Mon, 30 Jul 2012 12:32:44 +0000 (14:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 31 Jul 2012 21:08:28 +0000 (23:08 +0200)
This is way too specific to microblaze-only. Remove this support to
introduce a more generic way to do support device tree kernels.

This reverts commit aaed42d15643e0cb64c96fa400a6097a19d19ef4.

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/Config.in
linux/linux.mk

index e0c1c7ec02a068857617d5ece8d36780bff07ab9..915b1b6192fd0a6d6cbefe925dd547728882ae56 100644 (file)
@@ -125,14 +125,6 @@ config BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE
        help
          Path to the kernel configuration file
 
-config BR2_LINUX_KERNEL_DTS_FILE
-    string "Device Tree dts file location"
-    depends on BR2_microblaze
-    help
-      Path from where the dts file has to be copied
-      The final "custom target" name depends on the
-      dts file name:
-          <name>.dts --> simpleImage.<name>
 #
 # Binary format
 #
index ca216a3e3d57058f7da90125c75619f42cee84bd..1b7e0b755d24345055dd71b2c6666abfc3c46fdf 100644 (file)
@@ -119,18 +119,6 @@ endef
 
 LINUX_POST_PATCH_HOOKS += LINUX_APPLY_PATCHES
 
-ifeq ($(KERNEL_ARCH),microblaze)
-# on microblaze, we always want mkimage
-LINUX_DEPENDENCIES+=host-uboot-tools
-
-define LINUX_COPY_DTS
-    if test -f "$(BR2_LINUX_KERNEL_DTS_FILE)" ; then \
-        cp $(BR2_LINUX_KERNEL_DTS_FILE) $(@D)/arch/microblaze/boot/dts ; \
-    else \
-        echo "Cannot copy dts file!" ; \
-    fi
-endef
-endif
 
 ifeq ($(BR2_LINUX_KERNEL_USE_DEFCONFIG),y)
 KERNEL_SOURCE_CONFIG = $(KERNEL_ARCH_PATH)/configs/$(call qstrip,$(BR2_LINUX_KERNEL_DEFCONFIG))_defconfig
@@ -145,8 +133,6 @@ define LINUX_CONFIGURE_CMDS
        $(if $(BR2_ARM_EABI),
                $(call KCONFIG_ENABLE_OPT,CONFIG_AEABI,$(@D)/.config),
                $(call KCONFIG_DISABLE_OPT,CONFIG_AEABI,$(@D)/.config))
-    $(if $(BR2_microblaze),
-        $(call LINUX_COPY_DTS))
        # As the kernel gets compiled before root filesystems are
        # built, we create a fake cpio file. It'll be
        # replaced later by the real cpio archive, and the kernel will be