tcl: make the libtcl writable in order to be stripped
authorRichard Genoud <richard.genoud@gmail.com>
Mon, 24 Jun 2013 08:40:56 +0000 (10:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 28 Jul 2013 14:20:11 +0000 (16:20 +0200)
The libtcl is installed with 0555 and that prevents it from being
stripped.

Signed-off-by: Richard Genoud <richard.genoud@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tcl/tcl.mk

index c145f57c2394e10a6fedafd4e435b6dbaf58e9a4..f1193d3ca0ae198fb5ee428ccfeb1a9e338091e9 100644 (file)
@@ -42,5 +42,12 @@ endef
 TCL_POST_INSTALL_TARGET_HOOKS += TCL_SYMLINK_TCLSH
 endif
 
+# library get installed read only, so strip fails
+define TCL_FIXUP_RO_LIB
+       chmod +w $(TARGET_DIR)/usr/lib/libtcl*
+endef
+
+TCL_POST_INSTALL_TARGET_HOOKS += TCL_FIXUP_RO_LIB
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))