perl-gd: fix build of native part
authorFrancois Perrad <fperrad@gmail.com>
Wed, 15 Feb 2017 07:42:12 +0000 (08:42 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Mar 2017 22:13:08 +0000 (23:13 +0100)
EUMM don't find .xs file in subdirectory (only .pm files are handled)
So, let move lib/GD.xs in the root directory.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/perl-gd/perl-gd.mk

index ea8fd5cddb4c197696cf3b683e29d5370e6abeb1..2ad966c15c7a6111929abd8df2c6effbdfd30556 100644 (file)
@@ -12,6 +12,11 @@ PERL_GD_LICENSE = Artistic or GPLv1+
 PERL_GD_LICENSE_FILES = LICENSE
 PERL_GD_PREFER_INSTALLER = EUMM
 
+define PERL_GD_MOVE_XS
+       mv $(@D)/lib/GD.xs $(@D)/GD.xs
+endef
+PERL_GD_POST_PATCH_HOOKS += PERL_GD_MOVE_XS
+
 PERL_GD_CONF_OPTS = \
        -options=FT,PNG \
        -lib_gd_path=$(STAGING_DIR)/usr \