vala: remove deprecated target package
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Wed, 30 Apr 2014 18:18:23 +0000 (20:18 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 1 May 2014 21:34:44 +0000 (23:34 +0200)
The vala target package has been deprecated since 2013.05 and thus can be
removed in 2014.05. The host vala support is left untouched.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
package/Config.in
package/pulseaudio/pulseaudio.mk
package/vala/Config.in [deleted file]
package/vala/vala.mk

index c3c430cd9295ce006b3d52482ae79f10e98c2bf7..023dfd3f206ec060da44e93fe57299c34f52ef58 100644 (file)
@@ -101,6 +101,14 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2014.05"
 
+config BR2_PACKAGE_VALA
+       bool "vala target package has been removed"
+       select BR2_LEGACY
+       help
+         The 'vala' target package has been removed since it has been
+         deprecated for more than four buildroot releases.
+         Note: the host vala package still exists.
+
 config BR2_TARGET_TZ_ZONELIST
        default BR2_PACKAGE_TZDATA_ZONELIST if BR2_PACKAGE_TZDATA_ZONELIST != ""
 
index 6888dc37094cc82b8ba189c96285ea639b7502fa..8bdc1c233c79fd866b1cec326e320e309a12a08a 100644 (file)
@@ -125,7 +125,6 @@ if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/tar/Config.in"
 endif
 source "package/tree/Config.in"
-source "package/vala/Config.in"
 source "package/yasm/Config.in"
 endmenu
 
index 98e49bd81b5ff91c73e0917d5210d374ada0cb50..94df387c1d32b2d36bc5f55dd06f2baf0c10e0cc 100644 (file)
@@ -100,13 +100,11 @@ else
 PULSEAUDIO_CONF_OPT += --disable-x11
 endif
 
-ifneq ($(BR2_PACKAGE_VALA),y)
 define PULSEAUDIO_REMOVE_VALA
        rm -rf $(TARGET_DIR)/usr/share/vala
 endef
 
 PULSEAUDIO_POST_INSTALL_TARGET_HOOKS += PULSEAUDIO_REMOVE_VALA
-endif
 
 ifeq ($(BR2_PACKAGE_PULSEAUDIO_DAEMON),y)
 define PULSEAUDIO_USERS
diff --git a/package/vala/Config.in b/package/vala/Config.in
deleted file mode 100644 (file)
index 239c003..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-config BR2_PACKAGE_VALA
-       bool "vala"
-       # We no longer support a toolchain on the target
-       depends on BR2_DEPRECATED_SINCE_2013_05
-       depends on BR2_USE_WCHAR # glib2
-       depends on BR2_TOOLCHAIN_HAS_THREADS # glib2
-       depends on BR2_USE_MMU # glib2
-       select BR2_PACKAGE_LIBGLIB2
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
-       select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
-       help
-         Compiler for the GObject type system.
-
-         http://live.gnome.org/Vala
-
-comment "vala needs a toolchain w/ wchar, threads"
-       depends on BR2_DEPRECATED_SINCE_2013_05
-       depends on BR2_USE_MMU
-       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
index 368e3f87addd32156f01a1e5ed6dd66cca3ecf73..9b0fd31a3d0d1c8e6d00261bb6efff2dfad8ac27 100644 (file)
@@ -11,17 +11,9 @@ VALA_SOURCE = vala-$(VALA_VERSION).tar.xz
 VALA_LICENSE = LGPLv2.1+
 VALA_LICENSE_FILES = COPYING
 
-VALA_DEPENDENCIES = host-flex host-bison libglib2 \
-               $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
-
-# Force Vala to not use the host xsltproc even if available, because it may or
-# may not work with Vala documentation (some versions of xsltproc segfault)
-VALA_CONF_ENV = ac_cv_path_XSLTPROC=:
-
 HOST_VALA_DEPENDENCIES = host-flex host-libglib2
 # Yes, the autoconf script understands ':' as "xsltproc is not
 # available".
 HOST_VALA_CONF_ENV = ac_cv_path_XSLTPROC=:
 
-$(eval $(autotools-package))
 $(eval $(host-autotools-package))