ding-libs: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:41:25 +0000 (22:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:27:24 +0000 (01:27 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

The BR2_USE_WCHAR dependency was only needed for gettext. But now, we
no longer need gettext unconditionally, so this dependency on
BR2_USE_WCHAR is removed.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ding-libs/Config.in
package/ding-libs/ding-libs.mk

index d397f291f0999b3e1b8494365a2c72705b732cb9..6dc2a80f8228b434520da9030aa2cc1f3832d5e1 100644 (file)
@@ -1,7 +1,5 @@
 config BR2_PACKAGE_DING_LIBS
        bool "ding-libs"
-       depends on BR2_USE_WCHAR || !BR2_NEEDS_GETTEXT
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
        select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        help
          The ding-libs packages contain a set of libraries used by
@@ -16,7 +14,3 @@ config BR2_PACKAGE_DING_LIBS
          structure (libini_config).
 
          https://git.fedorahosted.org/git/ding-libs.git
-
-comment "ding-libs needs a toolchain w/ wchar"
-       depends on BR2_NEEDS_GETTEXT
-       depends on !BR2_USE_WCHAR
index 4b045be0b9bb128fc250d0330b2b0285bb9c40e2..e9508ccf9e3e88c660804904cc3ddfa5c40e239c 100644 (file)
@@ -8,7 +8,7 @@ DING_LIBS_VERSION = 0_4_0
 DING_LIBS_SOURCE = ding_libs-$(DING_LIBS_VERSION).tar.xz
 DING_LIBS_SITE = https://git.fedorahosted.org/cgit/ding-libs.git/snapshot
 DING_LIBS_DEPENDENCIES = host-pkgconf \
-       $(if $(BR2_PACKAGE_GETTEXT),gettext) \
+       $(TARGET_NLS_DEPENDENCIES) \
        $(if $(BR2_PACKAGE_LIBICONV),libiconv)
 DING_LIBS_INSTALL_STAGING = YES
 DING_LIBS_LICENSE = LGPL-3.0+ (library),GPL-3.0+ (test programs)