micropython: add upstream patch to fix build failures
authorChris Packham <judge.packham@gmail.com>
Sun, 11 Sep 2016 21:19:03 +0000 (09:19 +1200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 12 Sep 2016 09:35:04 +0000 (11:35 +0200)
This allows micropython to build with a host python version of 2.6.

Fixes:
  http://autobuild.buildroot.net/results/212cee82cc9db81cf1524925d106e01fc1e62ce5
  http://autobuild.buildroot.net/results/4f72a602702f4eac1fe8c4a385ebfeb6e1c50df2

Signed-off-by: Chris Packham <judge.packham@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/micropython/micropython.hash
package/micropython/micropython.mk

index a8ad2ba4d2bd6716ff18b3ae37b1e88c5c627092..28c008d3b956447fc4ec0624ad77c31417f72e51 100644 (file)
@@ -1,3 +1,4 @@
 #locally computed
 sha256 871378fcf1f1042c399896d5673da67d12e1fb36c2e706af289fc959bc8f7a57  micropython-v1.8.3.tar.gz
 sha256 ff3194ebecda99023d7c1bb94d32b31b9491e95a79958a25ffd05213c5553acc  8c6856d2e76c5865d9f30cad2c51615d4a1a1418.patch
+sha256 ac19af8587211d7229074fefa1a3a3c0fe807babc7cf9ce53606f05958699448  a50b26e4b00ed094aa1ac74eac2fc2d8eb9ea1ed.patch
index 590956e8465b2dc8695f0b3d805216501b97763a..2f47ad899625ffcd11e1cb6b6d5d3b4d806ad987 100644 (file)
@@ -9,7 +9,8 @@ MICROPYTHON_SITE = $(call github,micropython,micropython,$(MICROPYTHON_VERSION))
 MICROPYTHON_LICENSE = MIT
 MICROPYTHON_LICENSE_FILES = LICENSE
 MICROPYTHON_DEPENDENCIES = host-pkgconf libffi
-MICROPYTHON_PATCH = https://github.com/micropython/micropython/commit/8c6856d2e76c5865d9f30cad2c51615d4a1a1418.patch
+MICROPYTHON_PATCH = https://github.com/micropython/micropython/commit/8c6856d2e76c5865d9f30cad2c51615d4a1a1418.patch \
+       https://github.com/micropython/micropython/commit/a50b26e4b00ed094aa1ac74eac2fc2d8eb9ea1ed.patch
 
 # Use fallback implementation for exception handling on architectures that don't
 # have explicit support.