project/Makefile.in: workaround issue with out-of-tree builds
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 26 Sep 2008 14:04:08 +0000 (14:04 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 26 Sep 2008 14:04:08 +0000 (14:04 -0000)
Other packages might also support Linux-style out of tree builds
with the O=<dir> syntax (E.G. Busybox does). As make automatically
forwards command line variable definitions those packages get very
confused. Fix this by telling make to not do so

project/Makefile.in

index 6aa1d43e92ad415c3bf21303e579d6ddc083e2e9..cc1043ba199e53e4a2d2857f681b1ae0d9076ac4 100644 (file)
@@ -32,6 +32,12 @@ ifdef O
 ifeq ("$(origin O)", "command line")
 BASE_DIR := $(shell mkdir -p $(O) && cd $(O) && pwd)
 $(if $(BASE_DIR),, $(error output directory "$(O)" does not exist))
+
+# other packages might also support Linux-style out of tree builds
+# with the O=<dir> syntax (E.G. Busybox does). As make automatically
+# forwards command line variable definitions those packages get very
+# confused. Fix this by telling make to not do so
+MAKEOVERRIDES =
 endif
 endif