package/pkg-kconfig: quote HOSTCC_NOCCACHE
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 29 Aug 2020 20:42:52 +0000 (22:42 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 30 Aug 2020 16:33:39 +0000 (18:33 +0200)
HOSTCC may contain spaces, so needs to be quoted.

Most of the places where it is already quoted use double-quotes, so we
use that.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/pkg-kconfig.mk

index 45faf50e71bdcd3a9393f97187c3ab6ddd027981..2aecf2e203bf23981e0744f313b09ee25aa08d9a 100644 (file)
@@ -28,7 +28,7 @@ define kconfig-package-update-config
 endef
 
 PKG_KCONFIG_COMMON_OPTS = \
-       HOSTCC=$(HOSTCC_NOCCACHE)
+       HOSTCC="$(HOSTCC_NOCCACHE)"
 
 # Macro to save the defconfig file
 # $(1): the name of the package in upper-case letters