python: enable IPv6 socket support
authorvsergeev <vsergeev@gmail.com>
Sun, 22 Apr 2012 01:03:16 +0000 (01:03 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 24 Apr 2012 20:57:05 +0000 (22:57 +0200)
Added patch to disable buggy_getaddrinfo test during configure when
cross-compiling.

[Peter: Remove --enable-ipv6 which is now handled globally]
Signed-off-by: Vanya Sergeev <vsergeev at gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/python/python-2.7-016-cross-compile-getaddrinfo.patch [new file with mode: 0644]

diff --git a/package/python/python-2.7-016-cross-compile-getaddrinfo.patch b/package/python/python-2.7-016-cross-compile-getaddrinfo.patch
new file mode 100644 (file)
index 0000000..dae3005
--- /dev/null
@@ -0,0 +1,15 @@
+Disable buggy_getaddrinfo configure test when cross-compiling with IPv6 support
+
+Signed-off-by: Vanya Sergeev <vsergeev at gmail.com>
+
+--- python-2.7.2.orig/configure.in     2012-04-22 06:52:09.361809545 -0400
++++ python-2.7.2/configure.in  2012-04-22 06:56:37.900634194 -0400
+@@ -3128,7 +3128,7 @@
+ AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)
+-if test $have_getaddrinfo = no -o "$ac_cv_buggy_getaddrinfo" = yes
++if test $have_getaddrinfo = no || test "$cross_compiling" != "yes" -a "$ac_cv_buggy_getaddrinfo" = yes
+ then
+       if test $ipv6 = yes
+       then