toolchain-external: add support for Linaro 2012.10 toolchain
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 25 Oct 2012 22:20:25 +0000 (22:20 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 26 Oct 2012 11:12:33 +0000 (13:12 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 105fb2a26ef76d6ccc8b2dddd57083fd06655eef..7a9ec1db87adb01b12e8157c9894c60f4c1446bd 100644 (file)
@@ -3,6 +3,22 @@ if BR2_TOOLCHAIN_EXTERNAL
 choice
        prompt "Toolchain"
 
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
+       bool "Linaro 2012.10"
+       depends on BR2_arm
+       depends on BR2_cortex_a8 || BR2_cortex_a9
+       select BR2_TOOLCHAIN_EXTERNAL_GLIBC
+       select BR2_INSTALL_LIBSTDCPP
+       help
+         Linaro toolchain for the ARM architecture. It uses Linaro
+         GCC 2012.10 (based on gcc 4.7), Linaro GDB 2012.10 (based on
+         GDB 7.5), eglibc 2.15. It generates code that runs on all
+         Cortex-A profile devices, but tuned for the Cortex-A9. The
+         code generated is Thumb 2, with the hard floating point
+         calling convention, and uses the VFPv3-D16 FPU instructions.
+
+         To use this toolchain, you must disable soft float usage.
+
 config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
        bool "Linaro 2012.09"
        depends on BR2_arm
@@ -637,6 +653,7 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_07
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08
        default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
+       default "arm-linux-gnueabihf"    if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM2010Q1
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201009
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103
index 43d747cad6d42b90d64b5f0aa8fa0c1377d913ba..a7e4ab624f0f47c7d1d0cf0a937d32e7490c6324 100644 (file)
@@ -205,6 +205,9 @@ TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.08-20120827_linux.
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09),y)
 TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.09/+download/
 TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.09-20120921_linux.tar.bz2
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10),y)
+TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.10/+download/
+TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2012.10-20121022_linux.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/mips/portal/package7401/public/mips-linux-gnu/
 TOOLCHAIN_EXTERNAL_SOURCE=mips-4.4-303-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2