util-linux: bump to v2.30.1
authorMarcus Hoffmann <m.hoffmann@cartelsol.com>
Sat, 29 Jul 2017 15:36:02 +0000 (17:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Jul 2017 20:25:58 +0000 (22:25 +0200)
- Drop patch 0002-column-fix-compilation-when-libc-lacks-wide-characte.patch
as it has been applied upstream
- Patch 0001-Revert-build-sys-ncurses-headers-cleanup.patch is still
required to fix ncursesw support.

Signed-off-by: Marcus Hoffmann <m.hoffmann@cartelsol.com>
Cc: "Carlos Santos" <casantos@datacom.ind.br>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/util-linux/0002-column-fix-compilation-when-libc-lacks-wide-characte.patch [deleted file]
package/util-linux/util-linux.hash
package/util-linux/util-linux.mk

diff --git a/package/util-linux/0002-column-fix-compilation-when-libc-lacks-wide-characte.patch b/package/util-linux/0002-column-fix-compilation-when-libc-lacks-wide-characte.patch
deleted file mode 100644 (file)
index 5c11db9..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-From 46a37cd25db592db878d5beccdf75d1accbbacb6 Mon Sep 17 00:00:00 2001
-From: Carlos Santos <casantos@datacom.ind.br>
-Date: Tue, 27 Jun 2017 13:18:48 -0300
-Subject: [PATCH] column: fix compilation when libc lacks wide-character
- support
-
-Commit 4762ae9d removed mtsafe_strtok() but left behind calls to wcstok
-and wcspbrk. This leads to build failures when libc does not have the
-wide-character functions, like some uClibc builds.
-
-Solve the problem by using strtok_r and strpbrk when HAVE_WIDECHAR is
-not defined.
-
-Fixes:
-  http://autobuild.buildroot.net/results/fd8a1a8e0cef3aeed9588540e8e663664f6b43aa
-  http://autobuild.buildroot.net/results/5ad73ea8b471321988c50d80a5e50d4504151dd6
-  http://autobuild.buildroot.net/results/04411b7280dc51ecd51236967981a42352bbeb3e
-
-Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
----
- text-utils/column.c | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/text-utils/column.c b/text-utils/column.c
-index be99f94..fb57b47 100644
---- a/text-utils/column.c
-+++ b/text-utils/column.c
-@@ -160,14 +160,22 @@ static wchar_t *local_wcstok(wchar_t *p, const wchar_t *separator, int greedy, w
-       wchar_t *result = NULL;
-       if (greedy)
-+#ifdef HAVE_WIDECHAR
-               return wcstok(p, separator, state);
-+#else
-+              return strtok_r(p, separator, state);
-+#endif
-       if (!p) {
-               if (!*state || !**state)
-                       return NULL;
-               p = *state;
-       }
-       result = p;
-+#ifdef HAVE_WIDECHAR
-       p = wcspbrk(result, separator);
-+#else
-+      p = strpbrk(result, separator);
-+#endif
-       if (!p)
-               *state = NULL;
-       else {
--- 
-2.7.5
-
index 02b82f60003e6874bf2256fe09b7be9e3c548314..6f0bafe9e4d8a8680423f873010c79187c1f8d62 100644 (file)
@@ -1,2 +1,2 @@
 # From https://www.kernel.org/pub/linux/utils/util-linux/v2.30/sha256sums.asc
-sha256 c208a4ff6906cb7f57940aa5bc3a6eed146e50a7cc0a092f52ef2ab65057a08d  util-linux-2.30.tar.xz
+sha256 1be4363a91ac428c9e43fc04dc6d2c66a19ec1e36f1105bd4b481540be13b841  util-linux-2.30.1.tar.xz
index 99cc77fbaa0ed2bc225c8eececc94a40a4be31dd..fc3266886912abb7f3f70fb895db798ac41dabe8 100644 (file)
@@ -5,7 +5,8 @@
 ################################################################################
 
 UTIL_LINUX_VERSION_MAJOR = 2.30
-UTIL_LINUX_VERSION = $(UTIL_LINUX_VERSION_MAJOR)
+UTIL_LINUX_VERSION_MINOR = 1
+UTIL_LINUX_VERSION = $(UTIL_LINUX_VERSION_MAJOR).$(UTIL_LINUX_VERSION_MINOR)
 UTIL_LINUX_SOURCE = util-linux-$(UTIL_LINUX_VERSION).tar.xz
 UTIL_LINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/util-linux/v$(UTIL_LINUX_VERSION_MAJOR)