Makefile: Remove more pkgconfig files
authorValentine Barshak <gvaxon@gmail.com>
Tue, 2 Oct 2012 08:52:15 +0000 (08:52 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 4 Oct 2012 21:03:48 +0000 (23:03 +0200)
The pkgconfig files are located in  /usr/lib/pkgconfig
and /usr/share/pkgconfig directories.
However, only /usr/lib/pkgconfig is removed when no
development files are needed in the target filesystem.

Remove pkgconfig directory from $(TARGET_DIR)/usr/share
as well if BR2_HAVE_DEVFILES is not set.

Signed-off-by: Valentine Barshak <gvaxon@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Makefile

index 6536bca9bf243d2f6e61590b912a9c9d2efba6b1..0128839e296ddb3980fe09d3ef75fe88d00c58ca 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -419,7 +419,8 @@ target-finalize:
 ifeq ($(BR2_HAVE_DEVFILES),y)
        ( support/scripts/copy.sh $(STAGING_DIR) $(TARGET_DIR) )
 else
-       rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/lib/pkgconfig $(TARGET_DIR)/usr/share/aclocal
+       rm -rf $(TARGET_DIR)/usr/include $(TARGET_DIR)/usr/share/aclocal \
+               $(TARGET_DIR)/usr/lib/pkgconfig $(TARGET_DIR)/usr/share/pkgconfig
        find $(TARGET_DIR)/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
        find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
 endif