prevent recursion in %_defconfig rules
authorJeremy Rosen <jeremy.rosen@openwide.fr>
Tue, 7 Jan 2014 16:22:07 +0000 (17:22 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 13 Jan 2014 08:59:44 +0000 (09:59 +0100)
Signed-off-by: Jérémy Rosen <jeremy.rosen@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile

index 7624f593d6d6dfc51c8eb06bbc72a829aac69aa9..9aa8536a0788dbeb357e3ececfdb2e9863ffa944 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -761,10 +761,14 @@ defconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
        @mkdir -p $(BUILD_DIR)/buildroot-config
        @$(COMMON_CONFIG_ENV) $< --defconfig=$(TOPDIR)/configs/$@ $(CONFIG_CONFIG_IN)
 
+$(TOPDIR)/configs/%_defconfig:;
+
 %_defconfig: $(BUILD_DIR)/buildroot-config/conf $(BR2_EXTERNAL)/configs/%_defconfig outputmakefile
        @mkdir -p $(BUILD_DIR)/buildroot-config
        @$(COMMON_CONFIG_ENV) $< --defconfig=$(BR2_EXTERNAL)/configs/$@ $(CONFIG_CONFIG_IN)
 
+$(BR2_EXTERNAL)/configs/%_defconfig:;
+
 savedefconfig: $(BUILD_DIR)/buildroot-config/conf outputmakefile
        @mkdir -p $(BUILD_DIR)/buildroot-config
        @$(COMMON_CONFIG_ENV) $< \