* Removed duplicate PCIUTILS_VERSION
authorNigel Kukard <nkukard@lbsd.net>
Thu, 1 Jan 2009 17:28:51 +0000 (17:28 -0000)
committerNigel Kukard <nkukard@lbsd.net>
Thu, 1 Jan 2009 17:28:51 +0000 (17:28 -0000)
* When installing pci.ids[.gz] the -D means create all components leading up, using $(@D) does not include the filename, the last directory component is then /usr/share. pci.ids[.gz] is therefore created as /usr/share/misc (misc being the filename). Using $@ fixes this, the directory path is created and the file is installed as /usr/share/misc/pci.ids[.gz] .

package/pciutils/pciutils.mk

index 784985e7cf3aab95738f71da2c06a282890e6030..f9cc6bc86f861eef3fd6f9bdb184b9abb7c1866d 100644 (file)
@@ -3,7 +3,6 @@
 # pciutils
 #
 #############################################################
-PCIUTILS_VERSION:=2.2.10
 PCIUTILS_VERSION:=3.0.1
 PCIUTILS_SOURCE:=pciutils-$(PCIUTILS_VERSION).tar.gz
 PCIUTILS_CAT:=$(ZCAT)
@@ -55,7 +54,7 @@ $(TARGET_DIR)/sbin/setpci: $(PCIUTILS_DIR)/.compiled
        $(STRIPCMD) $(STRIP_STRIP_ALL) $@
 
 $(TARGET_DIR)/usr/share/misc/$(PCIIDS_FILE): $(PCIUTILS_DIR)/.unpacked
-       $(INSTALL) -D $(PCIUTILS_DIR)/$(PCIIDS_FILE) $(@D)
+       $(INSTALL) -D $(PCIUTILS_DIR)/$(PCIIDS_FILE) $@
 
 pciutils: uclibc $(if $(BR2_PACKAGE_ZLIB),zlib) $(TARGET_DIR)/sbin/setpci $(TARGET_DIR)/sbin/lspci $(TARGET_DIR)/usr/share/misc/$(PCIIDS_FILE)