network-manager: Add option for OpenVSwitch support
authorPetr Vorel <petr.vorel@gmail.com>
Thu, 1 Feb 2018 23:45:16 +0000 (00:45 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 3 Feb 2018 22:23:51 +0000 (23:23 +0100)
Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/network-manager/Config.in
package/network-manager/network-manager.mk

index 37e9b2fd8c7fea3f004379e6c13b3147abb25863..72658c12782dc524772182df79bf58bbc248b0d5 100644 (file)
@@ -56,6 +56,12 @@ config BR2_PACKAGE_NETWORK_MANAGER_PPPD
 comment "pppd support needs a glibc or uClibc toolchain"
        depends on BR2_TOOLCHAIN_USES_MUSL
 
+config BR2_PACKAGE_NETWORK_MANAGER_OVS
+       bool "OpenVSwitch support"
+       select BR2_PACKAGE_JANSSON
+       help
+         This option enables support for OpenVSwitch
+
 endif
 
 comment "NetworkManager needs udev /dev management and a glibc toolchain w/ headers >= 3.7, dynamic library"
index ccf376d0d8fb062177594ef2835c6648583ec4b2..a520aad9c0073392e49548c502fa069884f9ebf7 100644 (file)
@@ -30,8 +30,7 @@ NETWORK_MANAGER_CONF_OPTS = \
        --with-crypto=gnutls \
        --with-iptables=/usr/sbin/iptables \
        --disable-ifupdown \
-       --disable-ifnet \
-       --disable-ovs
+       --disable-ifnet
 
 ifeq ($(BR2_PACKAGE_OFONO),y)
 NETWORK_MANAGER_DEPENDENCIES += ofono
@@ -76,6 +75,13 @@ ifeq ($(BR2_PACKAGE_DHCPCD),y)
 NETWORK_MANAGER_CONF_OPTS += --with-dhcpcd=/sbin/dhcpcd
 endif
 
+ifeq ($(BR2_PACKAGE_NETWORK_MANAGER_OVS),y)
+NETWORK_MANAGER_CONF_OPTS += --enable-ovs
+NETWORK_MANAGER_DEPENDENCIES += jansson
+else
+NETWORK_MANAGER_CONF_OPTS += --disable-ovs
+endif
+
 # uClibc by default doesn't have backtrace support, so don't use it
 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
 NETWORK_MANAGER_CONF_OPTS += --disable-crashtrace