package/python3-six: add python3 host variant
authorChan, Donald <hoiho@lab126.com>
Thu, 20 May 2021 01:47:26 +0000 (01:47 +0000)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 6 Jun 2021 20:21:30 +0000 (22:21 +0200)
Add a python3 host variant since we are adding a python3 host variant of
python-cryptography and it is dependent on this.

Signed-off-by: Donald Chan <hoiho@lab126.com>
[yann.morin.1998@free.fr: also add sync comment in python-six]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/python-six/python-six.mk
package/python3-six/python3-six.hash [new symlink]
package/python3-six/python3-six.mk [new file with mode: 0644]

index e7621f5ecb18400299f125868247c427ef75ea67..7c298d6f896aca77a19a56db4bc8cbccedbb2ec7 100644 (file)
@@ -4,6 +4,7 @@
 #
 ################################################################################
 
+# Please keep in sync with package/python3-six/python3-six.mk
 PYTHON_SIX_VERSION = 1.15.0
 PYTHON_SIX_SOURCE = six-$(PYTHON_SIX_VERSION).tar.gz
 PYTHON_SIX_SITE = https://files.pythonhosted.org/packages/6b/34/415834bfdafca3c5f451532e8a8d9ba89a21c9743a0c59fbd0205c7f9426
diff --git a/package/python3-six/python3-six.hash b/package/python3-six/python3-six.hash
new file mode 120000 (symlink)
index 0000000..ed8cb89
--- /dev/null
@@ -0,0 +1 @@
+../python-six/python-six.hash
\ No newline at end of file
diff --git a/package/python3-six/python3-six.mk b/package/python3-six/python3-six.mk
new file mode 100644 (file)
index 0000000..debd338
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# python3-six
+#
+################################################################################
+
+# Please keep in sync with package/python-six/python-six.mk
+PYTHON3_SIX_VERSION = 1.15.0
+PYTHON3_SIX_SOURCE = six-$(PYTHON3_SIX_VERSION).tar.gz
+PYTHON3_SIX_SITE = https://files.pythonhosted.org/packages/6b/34/415834bfdafca3c5f451532e8a8d9ba89a21c9743a0c59fbd0205c7f9426
+PYTHON3_SIX_SETUP_TYPE = setuptools
+PYTHON3_SIX_LICENSE = MIT
+PYTHON3_SIX_LICENSE_FILES = LICENSE
+HOST_PYTHON3_SIX_DL_SUBDIR = python-six
+HOST_PYTHON3_SIX_NEEDS_HOST_PYTHON = python3
+
+$(eval $(host-python-package))