util-linux: do not install bash completion files
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Apr 2014 21:47:05 +0000 (23:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 20 Apr 2014 21:47:05 +0000 (23:47 +0200)
In most embedded systems, there is not much point in installing bash
completion files, especially since bash may not necessarily be present
on the target.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/util-linux/util-linux.mk

index cc57088f9b05d73745ef2d8497e127eda00dd024..4b8f731ff3f48a04095777f4467424bcbba3f5b2 100644 (file)
@@ -18,7 +18,10 @@ UTIL_LINUX_AUTORECONF = YES
 UTIL_LINUX_INSTALL_STAGING = YES
 UTIL_LINUX_DEPENDENCIES = host-pkgconf
 UTIL_LINUX_CONF_ENV = scanf_cv_type_modifier=no
-UTIL_LINUX_CONF_OPT += --disable-rpath --disable-makeinstall-chown
+UTIL_LINUX_CONF_OPT += \
+       --disable-rpath \
+       --disable-makeinstall-chown \
+       --disable-bash-completion
 
 # We don't want the host-busybox dependency to be added automatically
 HOST_UTIL_LINUX_DEPENDENCIES = host-pkgconf