neon: fix compilation without xml support
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 26 Aug 2008 20:47:12 +0000 (20:47 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 26 Aug 2008 20:47:12 +0000 (20:47 -0000)
webdav needs xml support, so disable it if no xml support is selected,
otherwise configure could get confused about a host xml2-config script.

package/neon/neon.mk

index 6eba627cd5da648c4f909328c772b74140f1fa1d..750217acc37257329130cc92830c48b86ce7983b 100644 (file)
@@ -21,5 +21,9 @@ NEON_CONF_OPT+=--with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
 NEON_CONF_OPT+=--with-libxml2=no
 NEON_DEPENDENCIES+=expat
 endif
+ifeq ($(strip $(BR2_PACKAGE_NEON_NOXML)),y)
+# webdav needs xml support
+NEON_CONF_OPT+=--disable-webdav
+endif
 
 $(eval $(call AUTOTARGETS,package,neon))