gvfs: Depend on libgcrypt if it is selected
authorMarkos Chandras <markos.chandras@imgtec.com>
Fri, 21 Jun 2013 14:41:31 +0000 (15:41 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 23 Jun 2013 19:45:02 +0000 (21:45 +0200)
gvfs can make optional use of libgcrypt so it needs to depend on
it if it is selected. It's also necessary to set the
ac_cv_path_LIBGCRYPT_CONFIG variable to a known value in order
to prevent the AM_PATH_LIBGCRYPT macro from searching the host
paths for the libgcrypt-config script.

Fixes the following build problem when libgcrypt is installed on the
host system but the package is not selected in buildroot:

gvfsbackendafpbrowse.c:31:20: fatal error: gcrypt.h: No such file or directory

Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gvfs/gvfs.mk

index d99c7843e76a2446bad7e03c64069d825f555d71..6e88f6eea18642d84c42817533a1d0b48f3bfd91 100644 (file)
@@ -12,6 +12,10 @@ GVFS_SITE = http://ftp.gnome.org/pub/GNOME/sources/gvfs/$(GVFS_VERSION_MAJOR)
 GVFS_INSTALL_STAGING = YES
 GVFS_DEPENDENCIES = host-pkgconf host-libglib2 libglib2 dbus shared-mime-info
 
+# Export ac_cv_path_LIBGCRYPT_CONFIG unconditionally to prevent
+# build system from searching the host paths.
+GVFS_CONF_ENV = ac_cv_path_LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-config
+
 GVFS_CONF_OPT = \
        --disable-gconf                 \
        --disable-cdda                  \
@@ -42,6 +46,10 @@ else
 GVFS_CONF_OPT += --disable-fuse
 endif
 
+ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+GVFS_DEPENDENCIES += libgcrypt
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSOUP),y)
 GVFS_DEPENDENCIES += libsoup
 GVFS_CONF_OPT += --enable-http