linux: use correct conditional for wireguard kernel config fixup
authorPeter Korsgaard <peter@korsgaard.com>
Sat, 15 Feb 2020 18:20:20 +0000 (19:20 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 16 Feb 2020 14:27:05 +0000 (15:27 +0100)
Commit de591c5c3a93 (package/wireguard-linux-compat: new package) split up
the wireguard package in wireguard-tools and wireguard-linux-compat, but
forgot to update the conditional in linux.mk, so the kernel config fixups
needed for wireguard are no longer applied.

Update the conditional to use the BR2_PACKAGE_WIREGUARD_LINUX_COMPAT symbol
instead.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/linux.mk

index bf308b807a4aaf65186981428269b993e693b7e7..4b60f33ff35fcd2b0be1432a567f2152f754e0e8 100644 (file)
@@ -392,7 +392,7 @@ define LINUX_KCONFIG_FIXUP_CMDS
                $(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK,$(@D)/.config)
                $(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK_MARK,$(@D)/.config)
                $(call KCONFIG_ENABLE_OPT,CONFIG_NF_NAT,$(@D)/.config))
-       $(if $(BR2_PACKAGE_WIREGUARD),
+       $(if $(BR2_PACKAGE_WIREGUARD_LINUX_COMPAT),
                $(call KCONFIG_ENABLE_OPT,CONFIG_INET,$(@D)/.config)
                $(call KCONFIG_ENABLE_OPT,CONFIG_NET,$(@D)/.config)
                $(call KCONFIG_ENABLE_OPT,CONFIG_NET_FOU,$(@D)/.config)