package/c-icap: add optional support for libmemcached
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 21 May 2017 21:41:20 +0000 (23:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 May 2017 13:39:39 +0000 (15:39 +0200)
Support for libmemcached was added in 2014:
https://sourceforge.net/p/c-icap/code/1103/#diff-2

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/c-icap/c-icap.mk

index 750b231c7c39d89cafa98780dcdc041c3c8ca685..e32e0dc15d47613cbe087b8551186347d9c5c897 100644 (file)
@@ -41,6 +41,13 @@ else
 C_ICAP_CONF_OPTS += --without-bzip2
 endif
 
+ifeq ($(BR2_PACKAGE_LIBMEMCACHED),y)
+C_ICAP_CONF_OPTS += --with-memcached
+C_ICAP_DEPENDENCIES += libmemcached
+else
+C_ICAP_CONF_OPTS += --without-memcached
+endif
+
 ifeq ($(BR2_PACKAGE_OPENLDAP),y)
 C_ICAP_CONF_OPTS += --with-ldap
 C_ICAP_DEPENDENCIES += openldap