oprofile: don't install shared library in BR2_STATIC_LIBS=y configs
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Nov 2015 20:29:47 +0000 (21:29 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Nov 2015 20:29:47 +0000 (21:29 +0100)
When building with BR2_STATIC_LIBS=y, no shared library gets built, so
the installation of libopagent.so* fails. This commit gets rid of this
installation step when BR2_STATIC_LIBS=y.

Fixes:

  http://autobuild.buildroot.net/results/2a6604622392a3f127fb61505e2751a88a90af7b/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/oprofile/oprofile.mk

index ba366403d230c35d080c3706aab63bc607ab3b27..c73086e0c739485a889664d54f7eb153b52480d2 100644 (file)
@@ -47,6 +47,12 @@ endif
 # a static build. We have to do the call to pkgconfig manually...
 OPROFILE_CONF_ENV += LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs popt`"
 
+ifeq ($(BR2_STATIC_LIBS),)
+define OPROFILE_INSTALL_SHARED_LIBRARY
+       $(INSTALL) -m 755 $(@D)/libopagent/.libs/*.so* $(TARGET_DIR)/usr/lib/oprofile
+endef
+endif
+
 define OPROFILE_INSTALL_TARGET_CMDS
        $(INSTALL) -d -m 755 $(TARGET_DIR)/usr/bin
        $(INSTALL) -d -m 755 $(TARGET_DIR)/usr/share/oprofile
@@ -57,7 +63,7 @@ define OPROFILE_INSTALL_TARGET_CMDS
        fi
        $(INSTALL) -m 644 $(@D)/libregex/stl.pat $(TARGET_DIR)/usr/share/oprofile
        $(INSTALL) -m 755 $(addprefix $(@D)/, $(OPROFILE_BINARIES)) $(TARGET_DIR)/usr/bin
-       $(INSTALL) -m 755 $(@D)/libopagent/.libs/*.so* $(TARGET_DIR)/usr/lib/oprofile
+       $(OPROFILE_INSTALL_SHARED_LIBRARY)
 endef
 
 $(eval $(autotools-package))