python-twisted: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Sun, 25 Jan 2015 23:47:30 +0000 (00:47 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 26 Jan 2015 13:25:18 +0000 (14:25 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/python-twisted/Config.in [new file with mode: 0644]
package/python-twisted/python-twisted.hash [new file with mode: 0644]
package/python-twisted/python-twisted.mk [new file with mode: 0644]

index 127ced341f4e68c2ea8326dec2eacb42a10533c5..51d4c152faae597811649c08ac3d0ebc3021267e 100644 (file)
@@ -548,6 +548,7 @@ menu "external python modules"
        source "package/python-simplejson/Config.in"
        source "package/python-thrift/Config.in"
        source "package/python-tornado/Config.in"
+       source "package/python-twisted/Config.in"
        source "package/python-urwid/Config.in"
        source "package/python-versiontools/Config.in"
        source "package/python-webpy/Config.in"
diff --git a/package/python-twisted/Config.in b/package/python-twisted/Config.in
new file mode 100644 (file)
index 0000000..b302101
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_TWISTED
+       bool "python-twisted"
+       depends on BR2_PACKAGE_PYTHON
+       select BR2_PACKAGE_PYTHON_ZOPE_INTERFACE # runtime
+       help
+         Twisted is an event-driven networking engine written in Python.
+
+         https://twistedmatrix.com/trac/
diff --git a/package/python-twisted/python-twisted.hash b/package/python-twisted/python-twisted.hash
new file mode 100644 (file)
index 0000000..937cab3
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256  038096be8723b678e2ead323b14d0d3e2db161e0c7ce3c98fdd18ca5869acb71  Twisted-14.0.2.tar.bz2
diff --git a/package/python-twisted/python-twisted.mk b/package/python-twisted/python-twisted.mk
new file mode 100644 (file)
index 0000000..792bb05
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-twisted
+#
+################################################################################
+
+PYTHON_TWISTED_VERSION = 14.0.2
+PYTHON_TWISTED_SOURCE = Twisted-$(PYTHON_TWISTED_VERSION).tar.bz2
+PYTHON_TWISTED_SITE = https://pypi.python.org/packages/source/T/Twisted/
+PYTHON_TWISTED_SETUP_TYPE = setuptools
+PYTHON_TWISTED_LICENSE = MIT
+PYTHON_TWISTED_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))