botan: disable documentation
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 11 Oct 2018 20:01:12 +0000 (22:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 11 Oct 2018 20:07:45 +0000 (22:07 +0200)
Fix following error if sphinx is found but its version is too low:
Sphinx version error:
This project needs at least Sphinx v1.2 and therefore cannot be built with this version.
Ignoring ImportError and using old theme
  ERROR: Error running sphinx-build -q -c ./src/configs/sphinx -b html ./doc/manual build/docs/manual

Fixes:
 - http://autobuild.buildroot.net/results/c15715a05a41035954f32510483314060ea31260

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/botan/botan.mk

index 3de54aa3e167fcbff0fe91cf201a5ea07b3dd1e4..7f0bbb66c967db8c85275c993aa25de56dffa366 100644 (file)
@@ -17,7 +17,8 @@ BOTAN_CONF_OPTS = \
        --os=linux \
        --cc=gcc \
        --cc-bin="$(TARGET_CXX)" \
-       --prefix=/usr
+       --prefix=/usr \
+       --without-documentation
 
 ifeq ($(BR2_SHARED_LIBS),y)
 BOTAN_CONF_OPTS += \