sunxi-mail: hack to work around autobuilder issue
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 3 Jul 2016 10:34:19 +0000 (12:34 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 3 Jul 2016 10:42:19 +0000 (12:42 +0200)
Fixes http://autobuild.buildroot.org/results/5a5/5a50be9feeb5da7694e9a42f615f0b7276319aeb/

The recent change to use git submodules for sunxi-mali instead of the github
wrapper without changing the version unfortunately doesn't work for people
who have already built sunxi-mali, as the existing github tarball will be
used instead of buildroot doing a clean git clone (with submodules).

The sunxi-mali commit we are using is the latest in the repo, so we cannot
fix it by bumping the version.  Instead simply remove the last character of
the VERSION sha1 so the existing tarballs are no longer used.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sunxi-mali/sunxi-mali.mk

index d621da18c7431df6f72507c2b3c1fc38f8e1a5e4..c808db6cf6aee42c3400472384b861a08b5e04b1 100644 (file)
@@ -4,7 +4,8 @@
 #
 ################################################################################
 
-SUNXI_MALI_VERSION = d343311efc8db166d8371b28494f0f27b6a58724
+# last sha1 character dropped to ensure unique filename
+SUNXI_MALI_VERSION = d343311efc8db166d8371b28494f0f27b6a5872
 SUNXI_MALI_SITE = https://github.com/linux-sunxi/sunxi-mali
 SUNXI_MALI_SITE_METHOD = git