qt5: support buildroot being located in /usr
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Sat, 21 Jun 2014 15:01:48 +0000 (17:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Jun 2014 10:39:57 +0000 (12:39 +0200)
qt5 performs sed replacements of /usr to $(STAGING_DIR)/usr in .la files.
However, if buildroot itself is located in /usr, then STAGING_DIR also
starts with /usr, and naive replacements of '/usr' can result in paths of
the form:
    /usr/buildroot/.../sysroot/usr/buildroot/.../sysroot/...

This patch makes the replacements more careful, by first replacing the known
paths BASE_DIR and STAGING_DIR to tokens, then performing the actual
replacement, and finally replacing the tokens with the corresponding paths.

Partially fixes bug #5750 (https://bugs.busybox.net/show_bug.cgi?id=5750)

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5.mk

index 44e5af02d8461596ddbd3a3a48962bd71a3be232..5f90eb5cc0c37e6d32c68fe90a1706654f7572d7 100644 (file)
@@ -5,7 +5,11 @@ include $(sort $(wildcard package/qt5/*/*.mk))
 
 define QT5_LA_PRL_FILES_FIXUP
        for i in $$(find $(STAGING_DIR)/usr/lib* -name "libQt5*.la"); do \
-               $(SED) "s:\(['= ]\)/usr:\\1$(STAGING_DIR)/usr:g" $$i; \
+               $(SED)  "s:$(BASE_DIR):@BASE_DIR@:g" \
+                       -e "s:\(['= ]\)/usr:\\1@STAGING_DIR@/usr:g" \
+                       -e "s:@STAGING_DIR@:$(STAGING_DIR):g" \
+                       -e "s:@BASE_DIR@:$(BASE_DIR):g" \
+                       $$i ; \
                $(SED) "/^dependency_libs=/s%-L/usr/lib %%g" $$i ; \
        done
        for i in $$(find $(STAGING_DIR)/usr/lib* -name "libQt5*.prl"); do \