mysql: Add optional OpenSSL dependency
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 17 May 2014 10:32:44 +0000 (12:32 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 17 May 2014 11:21:13 +0000 (13:21 +0200)
Make sure OpenSSL is built before mysql.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mysql/mysql.mk

index d338c317461e912dcefa3681f109f45af9f174ea..808abcea45d50e19323a8b88946c5767a85f2816 100644 (file)
@@ -33,6 +33,10 @@ MYSQL_CONF_OPT = \
        --enable-thread-safe-client \
        --disable-mysql-maintainer-mode
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+MYSQL_DEPENDENCIES += openssl
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 MYSQL_DEPENDENCIES += zlib
 endif