cairo: add missing dependency on xlib_libXext
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Jan 2013 00:40:54 +0000 (00:40 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 19 Jan 2013 18:22:49 +0000 (19:22 +0100)
The X.org backend of Cairo now requires xlib_libXext. See
http://permalink.gmane.org/gmane.comp.lib.cairo/23385.

Fixes:

 http://autobuild.buildroot.org/results/795404665ec74a7ac929fdf8caf1397c9c54d80d/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/cairo/Config.in
package/cairo/cairo.mk

index 89bd315f373143ac06862186c08fc0e9238c0a94..9a177a744a8f2ed8cacde9b6464b97e116c2f81b 100644 (file)
@@ -3,6 +3,7 @@ config BR2_PACKAGE_CAIRO
        select BR2_PACKAGE_PIXMAN
        select BR2_PACKAGE_FONTCONFIG
        select BR2_PACKAGE_XLIB_LIBX11 if BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_XLIB_LIBXEXT if BR2_PACKAGE_XORG7
        help
          Cairo is a 2D graphics library with support for multiple
          output devices. Currently supported output targets include
index ab0615c9e62fee26e22a77dcf6ed94f8bd27e3b1..83c82c03c8cb474d6cb80c4e17ab559fceed5ad6 100644 (file)
@@ -51,7 +51,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_XORG7),y)
        CAIRO_CONF_OPT += --enable-xlib --enable-xcb --with-x
-       CAIRO_DEPENDENCIES += xlib_libX11
+       CAIRO_DEPENDENCIES += xlib_libX11 xlib_libXext
 else
        CAIRO_CONF_OPT += --disable-xlib --disable-xcb --without-x
 endif