package/kmsxx: remove erroneous use of static-libc option
authorTomi Valkeinen <tomi.valkeinen@ideasonboard.com>
Fri, 6 Aug 2021 12:50:46 +0000 (15:50 +0300)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 8 Aug 2021 08:49:50 +0000 (10:49 +0200)
Currently, for a static-only build, we pass -Dstatic-libc=true. The
reason for that was not recorded when the package was converted to
meson.

The -Dstatic-libc=true option, despite its name, is not about linking
statically against libc, but against libgcc and libstdc++.

In Buildroot, we forcibly pass -static when calling the compiler and
linker, so everything is already linked statically.

For a shared build, -Dstatic-libc=false has no effect at all.

Drop this option altogether, as it is not needed, and is confusing.

Signed-off-by: Tomi Valkeinen <tomi.valkeinen@ideasonboard.com>
[yann.morin.1998@free.fr: expand commit log]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/kmsxx/kmsxx.mk

index fd40ff8e732dae6594142b885a90a8bb115d3b51..871ecaf85cefab265f6302682dd92c49fe7b204e 100644 (file)
@@ -17,12 +17,6 @@ KMSXX_CONF_OPTS = \
        -Duse-system-fmt=true \
        -Duse-system-pybind11=true
 
-ifeq ($(BR2_STATIC_LIBS),y)
-KMSXX_CONF_OPTS += -Dstatic-libc=true
-else
-KMSXX_CONF_OPTS += -Dstatic-libc=false
-endif
-
 ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
 KMSXX_CXXFLAGS += $(TARGET_CXXFLAGS) -O0
 endif