zxing: don't select libiconv
authorMartin Bark <martin@barkynet.com>
Sat, 1 Feb 2014 21:03:01 +0000 (21:03 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 2 Feb 2014 09:52:27 +0000 (10:52 +0100)
The zxing package currently selects libiconv when locale support is not
available in the toolchain.  This patch stops the zxing package selecting
libiconv.  The zxing package now uses uses libiconv if it's available
otherwise iconv support is disabled in zxing.

Signed-off-by: Martin Bark <martin@barkynet.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/zxing/Config.in
package/zxing/zxing.mk

index b69dfc9230cbd08233f0e76c6305109e2664cc75..1e04635fabf66cae4656b3c16bf241c00eb1d420 100644 (file)
@@ -4,7 +4,6 @@ comment "zxing needs a toolchain w/ C++"
 config BR2_PACKAGE_ZXING
        bool "zxing"
        depends on BR2_INSTALL_LIBSTDCPP
-       select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        help
          ZXing (pronounced "zebra crossing") is an open-source,
          multi-format 1D/2D barcode image processing library
index 367a84f54a3e7872501d0217864deb4d86993119..5942167fde8165889803ad84654f86e063029a0d 100644 (file)
@@ -12,7 +12,13 @@ ZXING_LICENSE_FILES = COPYING
 ZXING_INSTALL_STAGING = YES
 
 ifneq ($(BR2_ENABLE_LOCALE),y)
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
 ZXING_DEPENDENCIES += libiconv
+else
+# There is no locale support in the toolchain and libiconv
+# is not available so disable iconv support in zxing
+ZING_MAKE_OPT=CXXFLAGS+="-DNO_ICONV"
+endif
 endif
 
 define ZXING_EXTRACT_CMDS
@@ -20,7 +26,7 @@ define ZXING_EXTRACT_CMDS
 endef
 
 define ZXING_BUILD_CMDS
-       $(MAKE) -C $(@D)/cpp/core/src $(TARGET_CONFIGURE_OPTS)
+       $(MAKE) -C $(@D)/cpp/core/src $(TARGET_CONFIGURE_OPTS) $(ZING_MAKE_OPT)
 endef
 
 define ZXING_INSTALL_STAGING_CMDS